Duke nisur që nga 1 shkurti, telefonat iPhone me versionin e iOS më të vjetër se 8 nuk do të suportojnë më Whatsapp, bashkë me telefonat Android me versionin 2.3.7 ose më poshtë.

Veç kësaj, Whatsapp nuk do të ofrojë më suport për të gjithë telefonat me sistemin “Ëindoës”, gjë që do ta bëjë dhe vetë Microsoft, në të njëjtën kohë.

Arsyeja është sepse versionet e reja të Whatsapp do të kenë gjëra që nuk janë ndërtuar për telefonët e vjetër, ndaj dhe nëse shkarkohet, Whatsapp mund të mos funksiononte normalisht.